Mouse (moused) problems

Didier Caamano nemesisdivina at
Wed Apr 13 17:54:43 PDT 2005

Greetings to all:


As the subject says, I am having a bit of problem with the mouse.  


I have been running FBSD 5.3 for about 2 weeks, X was working wonderfully, I
even manage to get my ports upgraded using CTM, happiness was everywhere.
Then came the moment to enable the sound system, I have an nforce chip.  I
went to /boot/kernel to see anything related to nforce but there was noting.
Then, following the Handbook, I tried kldload snd_pcm but no sound still,
tried kldload sbd_driver but still nothing.  Tired of trying and reaching no
positive results I went to bed, the next time I booted FBSD the mouse was


My /etc/rc.conf and /etc/X11/xorg.conf looks as follow:



# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.


Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/sysmouse"
Option "ZAxisMapping" "4 5"


I ran /etc/rc.d/moused start and it gave no error message, not even an echo
saying it was starting moused.  Then I looked for sysmouse with: find /
-name sysmouse -print but the only result I got was /dev/sysmouse (because
it is supposed to be there); however, when I did an ls /dev sysmouse wasn't
there, I tried ls -a but nothing.

Any help regarding this will be appreciated.  I was really having fun with
FBSD until this little mouse incident and I don't want to redo the
installation and upgrading of the ports.

Have a nice day

More information about the freebsd-stable mailing list