Problems with PCI-express video card

Stephen Montgomery-Smith stephen at
Wed Apr 6 19:12:37 PDT 2005

I have a nvidia PCI-express 6600 video card on an Intel SE7525GP2 
motherboard.  I am running a fairly recent version of RELENG_5.

I am having great difficulty getting the video card to work.  On an 
older version of Xorg it would try to use the vesa driver.  It did put 
up some video, but it was illegible.

The most recent version of Xorg tries to use the nv driver.  I have also 
tried out the very recent nvidia driver that just came out on the nvidia 
website a few days ago.  In these cases startx simply doesn't work, and 
I get the error messages:

(EE) NVIDIA(0): No valid FB address in PCI config space

I might add that when the nvidia.ko is loading, it puts out messages 
like this:

pci3: <ACPI PCI bus> on pcib3
nvidia0: <GeForce 6600> mem 
00-0xdbffffff at device 0.0 on pci3
nvidia0: NVRM: NVIDIA MEM resource alloc failed.
nvidia0: NVRM: NVIDIA driver alloc failed.
device_attach: nvidia0 attach returned 6

I have tried also messing with the AGP settings to no avail, but I guess 
that is irrelevant anyway (is AGP totally unrelated to PCI-express?)

I don't know if this is a video card issue, or a motherboard issue, or 
what.  It works beautifully with Windows XP.  I might try it out with 
Linux also, but I haven't got that far yet.

Thanks, Stephen

More information about the freebsd-stable mailing list