ZFS: i/o error - all block copies unavailable

Kurt Lidl lidl at pix.net
Wed Jan 27 16:00:24 UTC 2016

On 1/27/16 5:39 AM, Subash Khati wrote:
> Hello Sir,
> I am trying to install FreeBSD Sparc64 on my machine, I followed the
> tutorials to Install FreeBSD Root on ZFS(tutorial link )
> <https://wiki.freebsd.org/RootOnZFS/VTOC8ZFSBoot/9.x-RELEASE>. Only the
> changes I made is that instead of using mirror I tried configuring raidz
> with four internal disks and added bootloader in all the disks (da0 da1
> da2 da3). Everything was fine while installing but booting after
> installation shows the error below:-
> |ZFS: i/o error - all block copies unavailable ZFS: can't read MOS
> object directory ZFS: can't find root filesystem FreeBSD/sparc64 ZFS
> enabled bootstrap loader, Revision 1.0 (root at releng1.nyi.freebsd.org,
> Wed Nov 12 03:13:59 UTC 2014) bootpath="" can't load 'kernel' |
> I created zpool like this:-
> zpool create -f -o altroot=/mnt -O canmount=off zroot raidz da0a da1a
> da2a da3a
> here is my bootloader installation:-
>   # zpool export zroot
>   # gpart bootcode -p /boot/zfsboot da0
>   # gpart bootcode -p /boot/zfsboot da1
>   # gpart bootcode -p /boot/zfsboot da2
>   # gpart bootcode -p /boot/zfsboot da3
>   # sysctl kern.geom.debugflags=0x10
>   kern.geom.debugflags: 0 -> 16
>   # dd if=/boot/zfsloader of=/dev/da0a bs=512 oseek=1024 conv=notrunc,sync
>   # dd if=/boot/zfsloader of=/dev/da1a bs=512 oseek=1024 conv=notrunc,sync
>   # dd if=/boot/zfsloader of=/dev/da2a bs=512 oseek=1024 conv=notrunc,sync
>   # dd if=/boot/zfsloader of=/dev/da3a bs=512 oseek=1024 conv=notrunc,sync
>   # zpool import -o altroot=/mnt zroot
> Any ideas?
> Thank You.

You didn't mention what version of FreeBSD you were trying to use.
If you didn't do this with 10.2, you'll probably be disappointed.

Did you put the following in the /boot/loader.conf on the


You steps are almost identical to the ones that I have used on my sparcs
running FreeBSD.  The biggest difference is that you're trying a to
use a zrail filesystem - I've only ever tried a zmirror.  The zmirror
option works great.


More information about the freebsd-sparc64 mailing list