FreeBSD 10-STABLE/sparc64 panic

Eric Benoit eric at
Tue May 13 22:28:02 UTC 2014

Just to clarify for the list, this particular issue is concerning a panic as
reported a while back on this list. Specifically:

spin lock 0xc0c63f30 (smp rendezvous) held by 0xfffff80003a70920 (tid 100059) too long
timeout stopping cpus
panic: spin lock held too long
cpuid = 1
KDB: stack backtrace:
#0 0xc05214f0 at _mtx_lock_spin_failed+0x50
#1 0xc05215b8 at _mtx_lock_spin_cookie+0xb8
#2 0xc088999c at tick_get_timecount_mp+0xdc
#3 0xc054379c at binuptime+0x3c
#4 0xc085366c at timercb+0x6c
#5 0xc0889d00 at tick_intr+0x220

> > It should be noted that of course 10-STABLE on amd64 is fine, and
> > also on a V100, which is of course uniprocessor.
>   Still with a bge?  I'm suspecting it's related to the bge, but as
> you note, it could just be network subsystem in general.

No, the V100 has a pair of dc interfaces.

I tried pulling the network cable and that had it come up without issue. I
then tried hooking up a an offboard bge NIC, and that worked in that I was able
to configure that manually with dhclient, etc.

I turned on rc_debug to get an idea where it was failing, which seemed to be
after bringing up bge0. I saw mention of ipv6_activate_all_interfaces which
I haven't set, and indeed:

bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

bge1: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500

I stopped the local router advertisement daemon briefly, and tested using the
original setup. Sure enough it came up as expected, minus a global IPv6
address (and routing).

It seems like it may be an issue with accepting IPv6 router advertisements,
at least when the system is first coming up. Once fully booted it seems fine.

Any ideas on how to proceed?

More information about the freebsd-sparc64 mailing list