Netbooting FBSD 9.1 from read-only medium: devices "disappear"

Joerg Wunsch j at
Wed Feb 27 16:55:47 UTC 2013

I just tried netbooting my elderly Netra t1, in order to install
a FreeBSD 9.1 straight from a CD image.  The machine doesn't have
a DVD drive, so netbooting was the most viable option.

Since this was only intended for installation, I mounted the CD image
on the netboot host through a MD device, and exported it read-only, as
if it were an actual CD-ROM.  The machine boots, I could newfs the
filesystems, but when trying to make the /mnt/var mountpoint, I got a
"read-only" filesystem even though I just mounted the newfs'ed root FS
on /mnt.  I umounted /mnt again, and tried to mount it again.  Much to
my surprise, I got a "No such file or directory".

Indeed, the entire contents of /dev was gone!

This is completely reproducible: netboot a 9.1 kernel, boot
single-user, wait for one minute, and /dev is empty.

I then extracted base.tgz from the CD image into a writable directory
on the netboot host, made this directory the client's root directory,
and all works fine.  Still, the client mounts its NFS root directory
read-only (as before), but this time, all works well.

Did anyone else try to netboot directly from an installation CD-ROM
(or an image thereof)?
cheers, Joerg               .-.-.   --... ...--   -.. .  DL8DTL
Never trust an operating system you don't have sources for. ;-)

More information about the freebsd-sparc64 mailing list