mount: /dev/da0p1: Invalid argument

Anton Shterenlikht mexas at
Fri Feb 8 12:01:59 UTC 2013

I need to transfer some files from sparc64 -current
box onto amd64 9.1-RELEASE laptop.
The amd64 laptop has no network connection yet,
so I'm trying to achive this with a USB flash drive. 

The problem is that I always end up with

# mount /dev/da0p1 /mnt/
mount: /dev/da0p1: Invalid argument

If I do newfs on the sparc64 box, then I can't
mount it on the amd64 box, and vice versa.

I tried just "newfs /dev/da0", and using gpart,

# gpart show /dev/da0
=>     34  4029373  da0  GPT  (1.9G)
       34     2048    1  freebsd-ufs  (1.0M)
     2082  4027325       - free -  (1.9G)


and then "newfs /dev/da0p1", or similar,
but no luck.

I tried sparc64 VTOC8 partition scheme too - no help.

I can mount the device and use it as expected,
i.e. copy files to/from it on either box, but
the other box doesn't seem to understand the file

I tried loading various modules in desperation,
e.g. on the sparc64 side:

# kldstat 
Id Refs Address            Size     Name
 1    9 0xc0000000 a80e58   kernel
 2    1 0x101bca000 104000   geom_part_mbr.ko
 3    1 0x101cce000 110000   geom_label.ko
 4    1 0x101dde000 108000   geom_part_gpt.ko

but still no use. 

Am I missing something simple?



More information about the freebsd-sparc64 mailing list