"short disk read" error during boot on Sparc SunFire v215

Leong, Jason (NSN - MY/Kuala Lumpur) jason.leong at nsn.com
Fri Sep 9 02:07:28 UTC 2011


Hi Marius,

Agreed, sorry but forgot to mention i did manage to install Debian and
Solaris on this box via the cdrom media! Anyway, great news! I was able
to boot iso9660 via sdb1, tweaking the boot device at OBP allowed me to
kickoff the installation...

{1} ok boot disk1:f
Boot device /pci at 1e,600000/pci at 0/pci at 1/pci at 0/pci at 8/scsi at 1/disk at 1,0:f
File and args:

>> FreeBSD.sparc64 boot block
   Boot path: /pci at 1e,600000/pci at 0/pci at 1/pci at 0/pci at 8/scsi at 1/disk at 1,0:f

   Boot loader: /boot/loader
Consoles: Open firmware console
...

 One problem after another, i found out it starts re-cycling after the
booloader kick in, problems with framebuffer or maybe an unsupported
graphics card! This i manage to find online to redirect input and output
to LOM's remote keyboard and screen from obp! Now I'm able to view
sysinstall via my network management port! First time for me :) Well,
keeping my fingers cross as I've yet to successfully install FreeBSD
yet! Thanks again Marius, i agree that a netboot would solve all my
problems and maybe it's something I'd play with as a next project! :)


Warmest regards, 
Jason Leong
Subscriber Data Management, Converged Core
Nokia Siemens Networks
Web: www.nokiasiemensnetworks.com 


-----Original Message-----
From: ext Marius Strobl [mailto:marius at alchemy.franken.de] 
Sent: Friday, September 09, 2011 5:42 AM
To: Leong, Jason (NSN - MY/Kuala Lumpur)
Cc: freebsd-sparc64 at freebsd.org; Saw, Jason (NSN - MY/Kuala Lumpur)
Subject: Re: "short disk read" error during boot on Sparc SunFire v215

On Thu, Sep 08, 2011 at 09:15:02AM +0300, Leong, Jason (NSN - MY/Kuala
Lumpur) wrote:
> Hi FreeBSD,
> 
> I've been trying to get FreeBSD installed into a SunFire v215 server
but
> am stumped with this problem!
> 
> {1} ok boot cdrom
> Boot device: /pci at 1e,600000/pci at 0/pci at 1/pci at 0/ide at 1f/cdrom0,0:f
> 
> Short disk read
> The file just loaded does not appear to be executable.
> 
> I've burned a bunch of CDs thus far, the
> FreeBSD-8.2-RELEASE-sparc64-dvd1.iso,
> FreeBSD-8.2-RELEASE-sparc64-bootonly.iso,
> FreeBSD-8.1-RELEASE-sparc64-disc1.iso,
> FreeBSD-7.4-RELEASE-sparc64-disc1.iso and none of them was able to
boot
> the system.
> Even tried the openbsd and netbsd's iso to no avail!
> 
> Even ended up flipping CD-drives between another working Sparc v215
> system. Didn't work too.
> 
> I've tried playing around with the boot devalias, tweaking the
> "cdrom0,0:f" to "cdrom6,0:f" and other sequences. Didn't help.
> 
> Last resort, I "dd" the image into a secondary hard-disk and booted
out
> of that but came out with the same error message! 

I'm not sure whether booting a ISO9660 image from a hard disk is
supported
by OBP at all.

> 
> Would you kind folks have an idea and a solution to this problem?
Thanks
> in advance for your help!
> 

Given that the problem even isn't limited to the FreeBSD install media
I'd highly suspect a hardware problem. If it isn't the drive it still
could be defective cabling or the IDE controller. On thing one has to
keep in mind with SPARC hardware is that at least for some models Sun
altered the generally IDE drives in some subtle ways so that off-the-
shelf drives from the PC world don't work with these. This is at least
the case for V210 (I can't remember the exact failure mode though).
One thing that might help is updating the OBP to the latest version in
case a previous one had some bug regarding booting from CD/DVD.
In general an alternative to installing from CD/DVD is to netboot the
machine and to install from that environment.

Marius



More information about the freebsd-sparc64 mailing list