"short disk read" error during boot on Sparc SunFire v215

Leong, Jason (NSN - MY/Kuala Lumpur) jason.leong at nsn.com
Thu Sep 8 06:55:27 UTC 2011

Hi FreeBSD,

I've been trying to get FreeBSD installed into a SunFire v215 server but
am stumped with this problem!

{1} ok boot cdrom
Boot device: /pci at 1e,600000/pci at 0/pci at 1/pci at 0/ide at 1f/cdrom0,0:f

Short disk read
The file just loaded does not appear to be executable.

I've burned a bunch of CDs thus far, the
FreeBSD-7.4-RELEASE-sparc64-disc1.iso and none of them was able to boot
the system.
Even tried the openbsd and netbsd's iso to no avail!

Even ended up flipping CD-drives between another working Sparc v215
system. Didn't work too.

I've tried playing around with the boot devalias, tweaking the
"cdrom0,0:f" to "cdrom6,0:f" and other sequences. Didn't help.

Last resort, I "dd" the image into a secondary hard-disk and booted out
of that but came out with the same error message! 

Would you kind folks have an idea and a solution to this problem? Thanks
in advance for your help!

Warmest regards, 
Jason Leong
Subscriber Data Management, Converged Core
Nokia Siemens Networks
Web: www.nokiasiemensnetworks.com <http://www.nokiasiemensnetworks.com/>

More information about the freebsd-sparc64 mailing list