Sil3512 (sii, SATA) driver on Sun Ultra60/blade 1000

Alexander Motin mav at FreeBSD.org
Thu Sep 24 16:19:20 UTC 2009


Hi.

R J wrote:
> I have been referred to you by Marius regarding the sii (Silicon Image)
> ata driver on sparc64.  The card I have is a two-port SATA card with the
> Sil3512 chipset.
> 
> You have perhaps seen some of my communication to the freebsd-sparc list
> earlier, but briefly, here's the problem I have had with it.
> 
> UNDER REL_ENG 7:
> 
> I have had a silicon image Sil 3512 in the ultra 60, and attached two
> disk drives.  The drives are seen by the ata driver.  I was able to lay
> a ufs file system on them, and even copied files onto the drives, but
> the system was not stable. I.e, I would copy files to the sata hard
> drives for a few minutes before it would hang and remain that way till I
> did a hard reset (power-off).  Usually there would be some message about
> the device detaching from the system, and the /dev/ad* entries disappear.
> 
> I then take the Sil 3512 out of the ultra60 and put it in the Sun blade
> 1000, and attach the disk drives; upon booting, the drives are not seen
> by the ata driver, although the controller is seen.  Remember, the
> drives are seen with the same card in the ultra60.
> 
> REBUILD TO 8.0 BETA on the Sun Blade 1000:
> 
> After I upgraded the Sun blade 1000 to 8.0 BETA, the ata driver could
> now see the disk attached to the Sil3512 controller, but the behaviour
> remains pretty much like on the Ultra60 under 7 stable if I put any i/o
> on the disks.
> 
> I have worked with Marius to get the ata-marvell driver sane for
> big-endian sparc64, and that driver now works on the Sun blade 1000
> under 8.0 BETA.  Before Marius fixed that driver, it was exhibiting the
> same behaviour as the Sil3512 under 8.0 Beta; i.e, the controller is
> seen, but no drives are seen, and the system wouldn't even finish
> booting if disks were attached to the controller.
> 
> Is it possible to for  you to take a look at the Sil ata driver again
> in-light of this information?

I have only tested SiI3114 chip from this family and only on i386/amd64.
It worked fine for me. Unfortunately, I have neither Sil3512 controller
nor sparc64 hardware for testing. Driver mentions about some errata for
this chip, but I am not aware about it and have no card to test it.

Have you tried newer SiI3124/3132 cards family with new siis(4) or old
ata(4) driver?

-- 
Alexander Motin


More information about the freebsd-sparc64 mailing list