Serial Port Troubleshooting

Steve Scally steve at
Tue May 19 18:44:31 UTC 2009

Marius & all,

First thank you for your responses.

On May 19, 2009, at 1:55 PM, Marius Strobl wrote:

> On Mon, May 18, 2009 at 11:49:14AM -0400, Steve Scally wrote:
>> Hello,
>> I currently have two machines one Ultra60  and one Dell GX400.  Both
>> of these boxes have two serial ports.  Currently port A on the Sun
>> goes to com2 on the Dell and com1 on the Dell goes to port B on the
>> Sun.    I upgraded my Ultra60 to FreeBSD 7.2 from 7.0 last night  
>> using
>> the serial connection from the Dell box.  However now when trying to
>> connect from the Sun to the Dell I only receive the "connected"  
>> string
>> and no prompt.  I also tried connecting to the Dell from the Sun and
>> then rebooting the dell from another terminal.  When the Dell box
>> reaches the multi-user prompt the terminal window with the serial
>> connection receives a question mark, "?."
> Does this imply that the low-level console works, i.e. you get
> the dmesg output of the kernel etc. but at the point getty(8)
> should take over things break?
> Does the other way work, i.e. can you login in to the Sun from
> the Dell machine?
> What happens if you connect each machine to itself and try to
> log in?
> Have you tried with something different than cu(1), f.e.
> minicom from ports?

To answer your questions.  I assume the low-level console is working  
if it is showing up the dmesg output.  Is there any other way to  
verify this?
I appears that yes at this point the failure is occurring when getty  
should be taking over, is there way to verify this as well?

I can indeed login to the Sun from the Dell using tip and cu, I have  
not tried minicom simply because cu worked before.

I will try tonight to remove all serial cables, reboot both boxes  
without any serial cables attached, then I will just attach the Sun to  
Dell setup and try again.

This is the only output I have from /var/log/aculog.


(Tue May 19 14:37:56 2009) <cu9600, , /dev/cuau0> call completed
(Tue May 19 14:38:21 2009) <cu9600, , /dev/cuau0> call terminated


(Tue May 19 14:35:55 2009) <cu9600, , /dev/cuad1> call completed
(Tue May 19 14:36:34 2009) <cu9600, , /dev/cuad1> call completed

Connecting Dell to Sun using cu -l /dev/cuad1

[root at buzz]% cu -l /dev/cuad1

FreeBSD/sparc64 (etch) (ttyu1)


Connecting Sun to Dell using cu -l /dev/cuau0

etch# cu -l /dev/cuau0

I appreciate your help and thanks again.

More information about the freebsd-sparc64 mailing list