"cg 0: bad magic number" with umass

Ari Sovijärvi listat at apz.fi
Fri Jun 26 04:00:15 UTC 2009

Hi folks!

I added a 1 terabyte USB harddisk to my Fire V100 for backups. I have recently 
used the same device with Linux and with i386 FreeBSD. I zeroed the disk and 
labeled it with sunlabel. However, newfs always dies with the error "cg 0: bad 
magic number". I also tried to label it into several smaller chunks, no luck.

I also tried to newfs the whole device without a disklabel, but that also ends 
with the same error.

Here's an example of the outcome, with 1 gigabyte partition:
# newfs /dev/da0b
/dev/da0b: 1027.6MB (2104512 sectors) block size 16384, fragment size 2048
         using 6 cylinder groups of 183.72MB, 11758 blks, 23552 inodes.
super-block backups (for fsck -b #) at:
  160, 376416, 752672, 1128928, 1505184, 1881440
cg 0: bad magic number

Here's bits of the dmesg, showing the drive:
umass0: <LaCie SA LaCie Hard Drive USB, class 0/0, rev 2.00/0.00, addr 2> on uhub0
da0 at umass-sim0 bus 0 target 0 lun 0
da0: <ST310005 28AS > Fixed Direct Access SCSI-2 device
da0: 1.000MB/s transfers
da0: 953869MB (1953525168 512 byte sectors: 255H 63S/T 121601C)

Any ideas of what's wrong?

Ari Sovijärvi

More information about the freebsd-sparc64 mailing list