getty or X problem on Ultra 10

Yousef Raffah yraffah at
Fri Nov 7 23:23:47 PST 2008

Hello Everyone,

This is the first time for me to play with FreeBSD on a SPARC64  
machine. I have Ultra 10 box sitting next to me doing nothing so I  
figured why not make use of that machine. The installation of 7- 
RELEASE went fine and everything seems to be normal on the Sun monitor  
connected to it through that "strange" cable. However, I want to hook  
it up to a bigger screen through the VGA card available on the same  
box and here starts my problem. When I connect the cable to any  
monitor from that VGA card (ATI Rage 3D) it shows nothing (white  
screen). I thought maybe I need to change some parameters with  
vidcontrol but I couldn't figure out how. Later on I decided to  
install X and give it a shot but that still didn't help. I tried  
different X configurations (Dual monitors as well as a simple single  
vga screen) but without any luck.

However, there is one thing I noticed, whenever the machine boots, I  
get some getty messages on the console complaining as:
open /dev/screen: No such file or directory
open /dev/ttya: No such file or directory
open /dev/ttyu2: No such file or directory

When I start X it spits out: xf86MapVidMem: could not mmap screen  
[s=2000, a=e2000000] (Invalid argument). Unfortunately googling that  
statement does bring out much of helpful threads, therefore, I thought  
of joining the team here to check if there is anything I can try or if  
any of you had such a problem and how it was solved, if it ever was :)

More information about the freebsd-sparc64 mailing list