7.0 RC1/SPARC64 panic in boot [SOLVED]

Marius Strobl marius at alchemy.franken.de
Sun Jan 27 14:40:19 PST 2008


On Wed, Jan 23, 2008 at 12:26:24PM +0100, Eirik verby wrote:
> On Jan 23, 2008, at 7:32 AM, Scott Long wrote:
> 
> >Eirik Øverby wrote:
> >>On Jan 22, 2008, at 7:23 PM, Marius Strobl wrote:
> >>>On Tue, Jan 22, 2008 at 07:16:16AM +0100, Eirik verby wrote:
> >>>>Hi list,
> >>>>
> >>>>by disabling the isp driver (set hint.isp.o.disabled=1), the  
> >>>>system  comes up. This of course denies us access to the external  
> >>>>disk array  hosted by the internal QLogic controller, but  
> >>>>pinpoints the problem.
> >>>>
> >>>>We tried setting hint.isp.0.prefer_iomap=1, which made no  
> >>>>difference  (though by reading the code, I don't see that it ever  
> >>>>used this).
> >>>>
> >>>>Can anyone help us out here?
> >>>
> >>>Scott, could this be due to a missing MFC of isp_sbus.c rev. 1.36?
> >>If that would be the case I'd be most happy to hear that. I'll also  
> >>be more than happy to test, and can do so on relatively short  
> >>notice (at least for another few hours).
> >>We have, for the record, gone through some basic troubleshooting:  
> >>Replaced memory (as this error also can show up under Solaris and  
> >>is usually an indicator of bad memory), replaced SCSI controller  
> >>with another one (still isp driven), and testing various device  
> >>hints - suffice to say we have wasted our time so far ;)
> >
> >Are you able to compile a new kernel without having to install first?
> >if so, apply the attached patch and let me know if it works.
> 
> Works very well, thanks a bunch!
> Will this make it into 7-RELEASE?
> 

Yes

Marius



More information about the freebsd-sparc64 mailing list