sparc64/91231: netboot installation fails on sparc64

Gianluca Camporeale gias at
Mon Jan 2 09:00:22 PST 2006

>Number:         91231
>Category:       sparc64
>Synopsis:       netboot installation fails on sparc64
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    freebsd-sparc64
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Mon Jan 02 17:00:15 GMT 2006
>Originator:     Gianluca Camporeale
>Release:        FreeBSD-6.0
During a netboot installation of FreeBSD6 on ultra2 and ultra5 machines, this is what happen on both machine after some minutes of interaction with the netboot server:

Sun Ultra 5/10 UPA/PCI (UltraSPARC-IIi 360MHz), No Keyboard
OpenBoot 3.19, 128 MB (60 ns) memory installed, Serial #12120549.
Ethernet address 8:0:20:b8:f1:e5, Host ID: 80b8f1e5.

ok boot net 
Boot device: /pci at 1f,0/pci at 1,1/network at 1,1  File and
args: 34e00 Consoles: Open Firmware console 
FreeBSD/sparc64 bootstrap loader, Revision
1.0 (root at, Wed Nov  2 09:45:36 UTC
bootpath="/pci at 1f,0/pci at 1,1/network at 1,1" boot: ethernet address:
net_open: server addr: 
net_open: server path: /sunboot
Loading /boot/defaults/loader.conf 
Fast Data Access MMU Miss 

OBP returns a Fast Data Access MMU Miss error. Same error with
last OBP firmware update.

Some log from bootpd:
[gias at blackdog:/home/gias]# /usr/libexec/bootpd -s -d 10
bootpd: info(6):   bootptab mtime: Tue Dec 27 19:35:08 2005
bootpd: info(6):   reading "/etc/bootptab"
bootpd: info(6):   read 3 entries (2 hosts) from "/etc/bootptab"
bootpd: info(6):   recvd pkt from IP addr
bootpd: info(6):   bootptab mtime: Tue Dec 27 19:35:08 2005
bootpd: info(6):   request from Ethernet address
bootpd: info(6):   found (sunboot)
bootpd: info(6):   bootfile="/sunboot/boot/kernel/kernel"
bootpd: info(6):   vendor magic field is
bootpd: info(6):   request message length=548
bootpd: info(6):   extended reply, length=548, options=312
bootpd: info(6):   sending reply (with RFC1048 options)
bootpd: info(6):   setarp - 08:00:20:B8:F1:E5

..and from tcpdump (blackdog is the netboot server)
20:20:05.389452 >  34 RRQ "/boot/kernel/linker.hints"
20:20:05.403160 > udp 516 
20:20:10.404403 > udp
20:20:15.414436 > udp 516 
20:20:20.424524 > udp
20:20:25.434735 > udp 516 
20:20:30.444670 > udp

It's strange that the netboot process stops in every tests when
ultra5/2 finish to fetch /boot/kernel/linker.hints from the
netboot server.
For netboot procedure I've preferred a tftp installation and
I've followed this guide:
Changes I made from the guide are: 
-No dhcp and nfs
-Files used on the netboot server are from FreeBSD6 disc1.iso
(and bootonly.iso in other tests). /boot has been copied
on /tftpboot and the iso has been mounted on /sunboot.
-tcpdump suggests me to execute portmap
This document "" 
suggests me that netbsd stuff has had same problem and has fixed it.


More information about the freebsd-sparc64 mailing list