sparc64/92033: dc(4) issues on Ultra10

John Baldwin jhb at
Tue Feb 7 07:53:04 PST 2006

On Monday 06 February 2006 20:10, Yasholomew Yashinski wrote:
> The following reply was made to PR sparc64/92033; it has been noted by
> From: Yasholomew Yashinski <yashy at>
> To: John Baldwin <jhb at>
> Cc: freebsd-sparc64 at, Doug White <dwhite at>,
>  freebsd-gnats-submit at
> Subject: Re: sparc64/92033: dc(4) issues on Ultra10
> Date: Mon, 06 Feb 2006 20:06:41 -0500
>  John Baldwin wrote:
>  >>>>dc0: <Macronix 98715/98715A 10/100BaseTX> port 0x400-0x4ff mem
>  >>>>0x1800000-0x18000ff at device 2.0 on pci2 miibus1: <MII bus> on dc0
>  >>>>dcphy0: <Intel 21143 NWAY media interface> on miibus1
>  >>>>dcphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
>  >>>>dc0: [GIANT-LOCKED]
>  >>>>
>  >>>>Unread portion of the kernel message buffer:
>  >>>>panic: trap: data access error
>  >>>>Uptime: 4m15s
>  >>>>Dumping 512 MB (2 chunks)
>  >>>>  chunk at 0: 268435456 bytes |
>  >>>
>  >>>Can you consistently reproduce this problem? If so, it is likely a
>  >>> device driver bug.  The data_access_error trap doesn't usually
>  >>> indicate a hardware issue.
>  >>
>  >>Yes. As noted below, as soon as dc0 is called upon, the kernel
>  >>cores. This happens every time dc0 is called upon.
>  >
>  > Can you figure out which instance of CSR_READ_4() or DC_CLRBIT() is
>  > triggering this panic?
>debug-online-ddb.html I've added:
>  options DDB
>  to my kernel.
>  When I try "boot -d" it just brings me up to a standard login prompt. So
>  I tried option two:
>  #  sysctl debug.enter_debugger=ddb
>  sysctl: unknown oid 'debug.enter_debugger'

This is different in 6.0, you would now do 'sysctl debug.kdb.enter=1'

>  at which point I went to the console and tried CTRL+ALT+ESC, in which
>  case the kernel appeared to core and the system rebooted. However it's
>  not recognized by gdb:
>  This GDB was configured as "sparc64-marcel-freebsd"...
>  "/var/crash/vmcore.8" is not a core dump: File format not recognized
>  while on this topic (the next page in the handbook):
>  # gdb -k /usr/obj/usr/src/sys/COLONEL/kernel
>  gdb: unrecognized option `-k'
>  Use `gdb --help' for a complete list of options.

Use 'kgdb' rather than 'gdb -k'.  However, what I would need you to do is add 
printf's or KTR traces to the dcphy_status() function before each
CSR_READ_4() or DC_CLRBIT() and use that to figure out which one is failing.

John Baldwin <jhb at>  <><
"Power Users Use the Power to Serve"  =

More information about the freebsd-sparc64 mailing list