failing to boot FreeBSD cdrom - openprom settings?

Donald Teed donald.teed at
Mon Nov 14 20:13:18 PST 2005

Hi there,

I have a boot CD for freebsd 6 on sparc - minimal boot only burned from ISO.

I want to test drive a FreeBSD install on a spare disk I have on the Ultra
60. Much earlier I had made a devalias in nvram for cdrom and this has
worked for booting such things as the sparc64 Gentoo CD.

Somehow boot-file in openprom was set to 'cprboot -F' - which was there
before I had the machine. openprom with a Linux CDROM normally just
complained about there being nothing after -F and then ignored boot-file.

I've tried 'setenv boot-file bsd' or boot/boot0 and various attempts to set
it to null, but I still cannot boot the FreeBSD boot only CDROM.

Perhaps really nulling boot-file would help but single and double quoted
null or no value have not worked.

So far no solutions found with google and nothing about it in the BSD
release notes, handbook, etc., so if anyone can suggest something to try it
would be great...

--Donald Teed

 [image: Edit/Delete

More information about the freebsd-sparc64 mailing list