Ultra Enterprise 2, Creator3D, type6, Xorg issues

Ken Folse ksfjr at sbcglobal.net
Mon Nov 14 10:52:49 PST 2005



I am using FreeBSD 6.0-RELEASE with xorg 6.8.2 installed on an Ultra
Enterprise 2 with a Creator3D series 3 card and (non-USB)type6 keyboard with
crossbow mouse. 

I would like to know if there are any guides to setting up xorg to run on
the sparc platform. I have tried google, but I just can't find any
documentation in regards to sparc. I found an X11R6 on SPARC FAQ, but it
should be more appropriately titled X11R6 on SOLARIS. I have been up and
down the various mail list archives, but haven't found a definitive "THIS


I have run X -configure and this tells me to run 'X -config
/root/xorg.conf.new'. When I run this, it loads X up to the grey screen with
the x cursor in the middle and freezes. I can usually Control+Alt+Backspace
out of this back to console. The Caps Lock, Scroll Lock, and Compose keys
light up but the Num Lock does not. 


If I hit Caps Lock on the console, the same keys light up and stick on.
However, I can toggle Caps Lock on and off. The lights just stay on.


I have run xorgcfg to similar results. It loads into X, then a small window
pops up, the screen goes black, goes back into X and then freezes. I can't
even Control+Alt+Backspace out of this. I log in via ssh and kill X to get


xorgconfig seems to be i386centric, so that's been a dead end.


I have experimented with changing the keyboard, mouse, and framebuffer
settings in the config files, but the results are always the same. I used
http://people.freebsd.org/~jake/XF86Config as a guide, but I have also tried
some of the settings other people have used in the mailing list.


I have read of previous problems with similar set ups, especially the type6,
but those were generally for older versions of FreeBSD and/or xorg.


Thanks for your time.

More information about the freebsd-sparc64 mailing list