vinum troubles

Maxim Mazurok maxim at km.ua
Thu Jan 13 06:00:34 PST 2005


strange troubles....
i have panic if i run `vinum start` from singleuser mode.
i have panic if i put string `vinum_start="YES"` into rc.conf.
i don't have panic if i run `vinum start` after full boot of OS.
i try compilling kernel width `device vinum` or widhout.
i try `kldload vinum` before `vinum start`.
and have same results.

root at fang:~#uname -r
5.3-RELEASE-p4

next example - from console in singleuser mode:

===
Mounting root from ufs:/dev/da0a
Enter full pathname of shell or RETURN for /bin/sh:
# bash
root@:/#kldstat
Id Refs Address            Size     Name
 1    1 0xc0000000 35a9f8   kernel
root@:/#kldload vinum
vinum: loaded
root@:/#kldstat
Id Refs Address            Size     Name
 1    2 0xc0000000 35a9f8   kernel
 2    1 0xc0536000 21c000   vinum.ko
root@:/#vinum start
panic: unmount: dangling vnode
Uptime: 26s
Cannot dump. No dump device defined.
Automatic reboot in 15 seconds - press a key on the console to abort
Rebooting...
Resetting ...
===

next example - from console after boot to multiuser mode:
===
root at fang:~#vinum list
0 drives:
0 volumes:
0 plexes:
0 subdisks:
root at fang:~#Jan 13 15:57:16 fang kernel: vinum: loaded
root at fang:~#vinum start
root at fang:~#Jan 13 15:57:23 fang kernel: vinum: reading configuration from /dev/da0e
root at fang:~#vinum list
1 drives:
D d1                    State: up       /dev/da0e       A: 0/6675 MB (0%)

1 volumes:
V var                   State: up       Plexes:       1 Size:       6675 MB

1 plexes:
P var.p0              C State: up       Subdisks:     1 Size:       6675 MB

1 subdisks:
S var.p0.s0             State: up       D: d1           Size:       6675 MB
root at fang:~#mount /dev/vinum/var /mnt
root at fang:~#df | grep vinum
/dev/vinum/var   6616402 1627506 4459584    27%    /mnt
root at fang:~#disklabel -r da0
Obsolete -r flag ignored
# /dev/da0:
text: FreeBSD9G cyl 1113 alt 2 hd 255 sec 63
bytes/sectors: 512
sectors/cylinder: 16065
sectors/unit: 17880345

8 partitions:
#
# Size is in sectors.
# Offset is in cylinders.
#    size       offset
#    ---------- ----------
  a:    2104515          0
  b:    2104515        131
  c:   17880345          0
  e:   13671315        262
===

where i wrong?

-- 
Maxim Mazurok  (MMP2-RIPE)


More information about the freebsd-sparc64 mailing list