Testers with U10/Creator wanted

Koop Mast kwm at rainbow-runner.nl
Mon Feb 28 23:17:58 GMT 2005

Op wo, 16-02-2005 te 14:22 +0100, schreef Marius Strobl:
>On Tue, Feb 15, 2005 at 03:34:52PM +0100, Koop Mast wrote:
>> Op di, 15-02-2005 te 02:04 +0100, schreef Marius Strobl:
>> >People who tried syscons(4) on Ultra 10 in the past reported a hang
>> >during boot after the screen is blanked. I managed to reproduce and
>> >fix this on a Sun AXi board. Could someone with a Creator(3D) or
>> >Elite3D equipped Ultra 10 please give the patch at:
>> >http://alchemy.franken.de/~marius/delay_fix.diff
>> >a try to see if it also solves the problem there? It shouldn't matter
>> >if you are running -stable or -current.
>> My hero!
>> Works fine on my Ultra10 here.
>> # Sun Ultra 5/10 UPA/PCI (UltraSPARC-IIi 360MHz), No Keyboard
>> # OpenBoot 3.31, 1024 MB (60 ns) memory installed, Serial #xxxxxxxx.
>> Only my monitor doesn't want to display anything. Probably a local
>> problem. Maybe something non related to the patch.
>The patch fixes DELAY() which would never return in certain situations
>when used early in boot. The excessive use of DELAY() in uart(4) when
>probing	Sun keyboards seems to always manage to trigger this.
>If you don't get display output then this should be another issue.
>Does the monitor work before FreeBSD is booted, i.e. do you see the
>Open Firmware banner etc.?
>So far I got one other reply in private mail stating that syscons(4)
>would work on U10 with the patch. Did the patch change anything for
>you, i.e. did you try syscons(4) on your U10 in the past and also
>got the mentioned hang?
>> I'm going to test this also on a Ultra1 with a creator card (non-3D).
>> But that can take a little while.
>As far as I can tell only UltraSparc II[e,i] based systems are affected
>by this issue so the patch shouldn't make any difference on an U1.
>Have you tried syscons(4) on that U1 before? There's probably a nit
>with creator(4) and old Creator cards that should be fixed but so far
>I didn't find a Creator card that is "old enough" to be affected. Could
>you please send me the output of `ofwdump -a -p` of that machine?

My Ultra1 (5.3-stable) is happily running syscons(4) with the tick

Thanks again for this patch.



More information about the freebsd-sparc64 mailing list