Call for testers: patch for the dc(4) driver
brad at stop.mail-abuse.org
Tue Sep 28 07:23:00 PDT 2004
At 2:40 PM +0200 2004-09-28, Maxime Henrion wrote:
> I need people to give this patch a try and see if it doesn't break
> anything. It shouldn't cause any harm, but better safe than sorry.
You mean this one:
DC(4) FreeBSD Kernel Interfaces Manual DC(4)
dc -- DEC/Intel 21143 and clone 10/100 ethernet driver
The dc driver provides support for several PCI fast ethernet adapters and
embedded controllers based on the following chipsets:
o DEC/Intel 21143
o ADMtek AL981 Comet, AN985 Centaur, ADM9511 Centaur II and
ADM9513 Centaur II
o ASIX Electronics AX88140A and AX88141
o Conexant LANfinity RS7112 (miniPCI)
o Davicom DM9009, DM9100, DM9102 and DM9102A
o Lite-On 82c168 and 82c169 PNIC
o Lite-On/Macronix 82c115 PNIC II
o Macronix 98713, 98713A, 98715, 98715A, 98715AEC-C, 98725, 98727
o Xircom X3201 (cardbus only)
> This patch allows the dc(4) driver to properly read the MAC address in
> the EEPROM on FreeBSD/powerpc. Andrew Gallatin tested it successfully
> on his G4. I'm particularly interested about people using dc(4) on
> sparc64 since this arcihtecture is big endian.
I think the first trick will be to find someone who actually has
a dc(4) card in a SPARC64 box.
Brad Knowles, <brad at stop.mail-abuse.org>
"Those who would give up essential Liberty, to purchase a little
temporary Safety, deserve neither Liberty nor Safety."
-- Benjamin Franklin (1706-1790), reply of the Pennsylvania
Assembly to the Governor, November 11, 1755
SAGE member since 1995. See <http://www.sage.org/> for more info.
More information about the freebsd-sparc64