5.3-BETA works on Naturetech 777S

Mykel Mykel at mWare.ca
Sat Sep 4 14:12:40 PDT 2004

see message ID 20040616085518.GA8881 at kt-is.co.kr

tho I haven't tried it yet. Still running the June14 snap... I should 
try the betas...


Hiroki Sato wrote:

> I tried 5.3-BETA2 on my sparc64 laptop[*] and it worked!
> The dmesg is attached.
> [*] http://www.dciplano.com/p777.html
> However, console (keyboard) is slow to respond and some of the
> typed characters are randomly lost.
>GENIALstation 777S (UltraSPARC-IIe 500MHz), Keyboard Present
>OpenBoot , 512 MB memory installed, Serial #XXXXXXX.
>Ethernet address X:X:X:X:X:X, Host ID: XXXXXXXX.
>Boot device: /pci at 1f,0/pci at 1,1/ide at d/cdrom at 2,0:f  File and args:
>>>FreeBSD/sparc64 boot block
>   Boot path:	/pci at 1f,0/pci at 1,1/ide at d/cdrom at 2,0:f
>   Boot loader: /boot/loader
>Console: Open Firmware console
>Boot path set to /pci at 1f,0/pci at 1,1/ide at d/cdrom at 2,0:a
>FreeBSD/sparc64 bootstrap loader, Revision 1.0
>(root at bobbi.cse.buffalo.edu, Fri Aug 27 14:45:48 UTC 2004)
>bootpath="/pci at 1f,0/pci at 1,1/ide at d/cdrom at 2,0:a"
>Loading /boot/defaults/loader.conf
>/boot/kernel/kernel data=0x3a8408+0x91658 syms=[0x8+0x51ab0+0x8+0x44b58]
>Hit [Enter] to boot immediately, or any other key for command prompt.
>Booting [/boot/kernel/kernel]... 1 second....
>Turning off DMA for ATA.
>jumping to kernel entry at 0xc0040000.
>GDB: no debug ports present
>KDB: debugger backends: ddb
>KDB: current backend: ddb
>Copyright (c) 1992-2004 The FreeBSD Project.
>Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
>	The Regents of the University of California. All rights reserved.
>FreeBSD 5.3-BETA2 #1: Sat Aug 28 21:55:40 UTC 2004
>    root at bobbi.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
>WARNING: WITNESS option enabled, expect reduced performance.
>Timecounter "tick" frequency 500000000 Hz quality 0
>real memory  = 536870912 (512 MB)
>avail memory = 500736000 (477 MB)
>cpu0: Sun Microsystems UltraSparc-IIe Processor (500.00 MHz CPU)
>nexus0: <Open Firmware Nexus device>
>pcib0: <U2P UPA-PCI bridge> on nexus0
>pcib0: Sabre, impl 0, version 0, ign 0x7c0, bus A
>pcib0: [FAST]
>pcib0: [GIANT-LOCKED]
>pcib0: [FAST]
>pcib0: [GIANT-LOCKED]
>pcib0 dvma: DVMA map: 0xc0000000 to 0xc3ffffff
>pci0: <OFW PCI bus> on pcib0
>pcib1: <APB PCI-PCI bridge> at device 1.1 on pci0
>pci1: <OFW PCI bus> on pcib1
>ebus0: <PCI-EBus3 bridge> mem 0xf1000000-0xf17fffff,0xf0000000-0xf0ffffff at device 12.0 on pci1
>ebus0: <idprom>: incomplete
>ebus0: <flashprom> addr 0x1000000000-0x10000fffff (no driver attached)
>eeprom0: <EEPROM/clock> addr 0x1400000000-0x1400001fff on ebus0
>eeprom0: model mk48t59
>eeprom0: hostid 8080019c
>ebus0: <flashprom> addr 0x1000400000-0x10007fffff (no driver attached)
>ebus0: <flashprom> addr 0x1000800000-0x1000bfffff (no driver attached)
>isab0: <PCI-ISA bridge> at device 7.0 on pci1
>isa0: <ISA bus> on isab0
>gem0: <Sun ERI 10/100 Ethernet Adaptor> mem 0xe0400000-0xe041ffff at device 12.1 on pci1
>miibus0: <MII bus> on gem0
>ukphy0: <Generic IEEE 802.3u media interface> on miibus0
>ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
>gem0: 2kB RX FIFO, 2kB TX FIFO
>gem0: Ethernet address: XX:XX:XX:XX:XX:XX
>fwohci0: <1394 Open Host Controller Interface> mem 0xe0422000-0xe04227ff,0xe0420000-0xe04207ff at device 12.2 on pci1
>fwohci0: Could not allocate irq
>device_attach: fwohci0 attach returned 6
>pci1: <serial bus, USB> at device 12.3 (no driver attached)
>pci1: <old, non-VGA display device> at device 3.0 (no driver attached)
>atapci0: <AcerLabs Aladdin UDMA66 controller> port 0x420-0x42f,0x408-0x40b,0x410-0x417,0x418-0x41b,0x400-0x407 at device 13.0 on pci1
>ata2: channel #0 on atapci0
>ata3: channel #1 on atapci0
>pci1: <display, VGA> at device 2.0 (no driver attached)
>pci1: <multimedia, audio> at device 8.0 (no driver attached)
>pcib2: <APB PCI-PCI bridge> at device 1.0 on pci0
>pci2: <OFW PCI bus> on pcib2
>Timecounters tick every 10.000 msec
>md0: Preloaded image </boot/mfsroot> 4194304 bytes at 0xc04d0078
>ad0: 19077MB <FUJITSU MHM2200AT/3822> [38760/16/63] at ata2-master PIO4
>ATAPI_RESET time = 20us
>acd0: DVDR <TOSHIBA DVD-ROM SD-C2502/1011> at ata3-master PIO4

More information about the freebsd-sparc64 mailing list