panic : trap : data access error with maxproc limits with FreeBSD 5.3 on SUN E450

Borghesi Guilhem borghesi at
Thu Oct 21 08:01:51 PDT 2004


Few days ago, I've posted a problem on a Sun Sparc64 E450 with FreeBSD 
5.3 Beta7 on it.

The problem was that when a user reaches the top limit of processes 
numbers (5547 by default), the server crashes with "panic: trap: data 
access error" message and then go for reboot.
The program use to test it was a simple "forkbomb".

I've found where the problem comes from. When I tried to make a trace 
bug with a notebook on the serial port, I've never managed to make it 
crash again. And then I tried to boot without video card and the trouble 
goes away.

I know that it sounds weird but it was the only way to make it works 

The card is a PCI RAPTOR GFX (-06 REV.50)

Well, maybe there's a driver trouble... Anyway, for the moment I'm using 
  my "old-friend" VT100 and it works without any problem.

Thanks for those who tried to find an answer to this strange bug !


Guilhem BORGHESI		 Tel : 03 90 24 02 09
Departement d'Informatique	 Fax : 03 90 24 03 29
Universite Louis Pasteur
7, rue Rene Descartes 67084 Strasbourg Cedex - FRANCE

More information about the freebsd-sparc64 mailing list