Minor sparc64 install-time questions

John-Mark Gurney gurney_j at efn.org
Mon Jan 5 23:32:09 PST 2004

Garance A Drosihn wrote this message on Mon, Jan 05, 2004 at 22:18 -0500:
> I just did an install of 5.2-rc2 on my Sparc Ultra-10 machine.
> That seems to have gone fine, but I have two questions.
> Right after booting up, the user is asked to pick a terminal
> type, from:
>     1 - standard ansi terminal
>     2 - vt100 or compatible
>     3 - freebsd system console (color)
>     4 - freebsd system console (mono)
>     5 - xterm terminal emulator
> None of those worked particularly great for me, although all
> of them seemed to work "to some degree".  I finally decided on
> choice #2, as that seemed to work the best in the disklabel
> step.  How does one know which to pick?

You need to know what type of terminal you are using.  If you are
using Windows Terminal, then 1 is probably best.. xterm + tip on
another box, then 5...  console + tip on a FreeBSD box, then 3 or 4..

> Also, is there any way to have more than 7 BSD partitions (in
> addition to 'c', of course) on a single hard disk?

possibly add another label to one of the partitions... I haven't
tried this, but it should work.. :)

> Also, are we supposed to be using 'bsdlabel' instead of
> 'disklabel' now?  I assume so, since there is no disklabel
> installed in my system...  When I go to run bsdlabel, it tells
> me that I *must* specify a -m architecture, even though the
> man page indicates that is optional.  The man page also does
> not say what valid values for 'arch' are (neither does the
> program).  Looking at the source, it seems that nothing
> sparc-ish is listed as a valid option.

on sparc you need to be using sunlabel to be compatible with openboot
to be able to boot the disk..

> I can do disklabeling chores via sysinstall, where it both
> works and also claims that it's the 'FreeBSD Disklabel Editor'.

Yep, lots of people use sysinstall for this..

> One last question, which may do nothing more than show how
> I am ignorant of some details.  After the install of 5.2-RC2
> onto a clean disk, /lib has a variety of "versioned" libraries,
> such as libutil.so.4.  However, it does not include any symlinks
> from the non-versioned name (eg: libutil.so) to one of the
> versioned files.  /usr/lib does seem to include such symlinks,
> as does /lib on my freebsd/i386 system.  Is this how /lib is
> expected to be on a new sparc64 install?

My upgraded (from source) system is the same way.  I haven't had any
problems, though I haven't used it much.. so I guess it's the way
it's suppose to be.. :)

  John-Mark Gurney				Voice: +1 415 225 5579

     "All that I will do, has been done, All that I have, has not."

More information about the freebsd-sparc64 mailing list