new to sparc64 -- build problems

Goodleaf, John M jgoodlea at
Thu Feb 5 07:57:39 PST 2004

Well I had in /etc/make.conf CPUTYPE=ultrasparc and -mcpu=ultrasparc was in
CFLAGS (with -O -pipe). I assumed I was safe in this because I had not put
it in COPTFLAGS. I've removed that ultrasparc bit and restarted a build,
which appears to be working, having already passed the point at which it's
always failed.

Although it may yet fail, it looks better. And in retrospect, I ought to
have thought of this, since I've tried much more obscure combinations of ENV
variables and whatnot to get it to work. I'm sorry I've wasted people's time
on something I ought to have figured out myself. How many times have I seen
folks told, on the -QUESTIONS list, not to put oddball optimization flags in
place for builds? Dang.


-----Original Message-----
From: Ken Smith [mailto:kensmith at cse.Buffalo.EDU]
Sent: Thursday, February 05, 2004 6:08 AM
To: Goodleaf, John M
Cc: 'freebsd-sparc64 at'
Subject: Re: new to sparc64 -- build problems

On Wed, Feb 04, 2004 at 09:48:29AM -0800, Goodleaf, John M wrote:

> I'm trying to buildworld (CURRENT) on a Sun Ultra 5. I always hit the
> following error, regardless of the cvsup date:
> cc -O -pipe -mcpu=ultrasparc -I. -static -DGENERATOR_FILE
> -DPREFIX=\"/usr\"
> -I/usr/obj/usr/src/gnu/usr.bin/cc/cc_tools/../cc_tools
> -I/usr/src/gnu/usr.bin/cc/cc_tools/../cc_tools
> -I/usr/src/gnu/usr.bin/cc/cc_tools/../../../../contrib/gcc
> -I/usr/src/gnu/usr.bin/cc/cc_tools/../../../../contrib/gcc/config 
> -I/usr/obj/usr/src/sparc64/legacy/usr/include -c
> /usr/src/gnu/usr.bin/cc/cc_tools/../../../../contrib/gcc/gencheck.c
> In file included from hconfig.h:1,
>                  from /usr/src/contrib/gcc/gencheck.c:21:
> /usr/src/gnu/usr.bin/cc/cc_tools/auto-host.h:320:2: #error "I don't
> know what arch this is."
> *** Error code 1
> Stop in /usr/src/gnu/usr.bin/cc/cc_tools.
> *** Error code 1
> I've tried setting the __sparc64__ and defining environment
> variables like MACHINE_ARCH, but it just doesn't work. Is this
> covered somewhere in some documentation I've not seen?

I did a cvsup to -current last night and started up a buildworld.  That
succeeded.  From the log file I got from the build the output for the
file you list above came out as:

cc -O -pipe -I. -static -DGENERATOR_FILE
-DPREFIX=\"/usr\" -I/usr/obj/usr/src/gnu/usr.bin/cc/cc_tools/../cc_tools
-I/usr/obj/usr/src/sparc64/legacy/usr/include -c

Yours has an extra "-mcpu=ultrasparc", that is the only difference I
see.  Is there anything in your environment (environment variables,
or maybe something in /etc/make.conf) that might account for where that
is coming from?  Or was the run you got this message from one where
you had tried setting environment variables yourself?

						Ken Smith
- From there to here, from here to      |       kensmith at
  there, funny things are everywhere.   |
                      - Theodore Geisel |

More information about the freebsd-sparc64 mailing list