Ultra AXe motherboard and additional NIC

Maxim Mazurok maxim at km.ua
Mon Nov 24 12:40:51 PST 2003

i need strange again :)))
i need small route-server (1U rack-mount form factor).
for this i have UltraAXe motherboard.
but i need more than one ethernet cards. and more, than two :)
i 1U i can install onmy one PCI card width riser.
i have 2 strange cards:
1. dual-port card width Intel 21143 chipset.
2. four-port card width Digital 21140A chipset.
i recompile kernel width dc(4) driver and de(4) driver...
reboot, and i see:

dc0: <Intel 21143 10/100BaseTX> port 0x1000-0x107f mem 0x100000-0x1003ff irq 16 at device 4.0 on pci3
dc0: Ethernet address: 00:00:1d:d1:06:82
miibus0: <MII bus> on dc0
dcphy0: <Intel 21143 NWAY media interface> on miibus0
dcphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
dc1: <Intel 21143 10/100BaseTX> port 0x1080-0x10ff mem 0x102000-0x1023ff irq 16 at device 8.0 on pci3
dc1: Ethernet address: ff:ff:ff:ff:ff:ff
miibus1: <MII bus> on dc1
dcphy1: <Intel 21143 NWAY media interface> on miibus1
dcphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

de0: <Digital 21140A Fast Ethernet> port 0x2000-0x207f mem 0x200000-0x20007f irq 24 at device 4.0 on pci4
de0: 21140A [10-100Mb/s] pass 2.2
de0: address 00:00:bc:11:74:87
de1: <Digital 21140A Fast Ethernet> port 0x2080-0x20ff mem 0x202000-0x20207f irq 25 at device 5.0 on pci4
de1: 21140A [10-100Mb/s] pass 2.2
de1: address 00:00:bc:11:74:86
de2: <Digital 21140A Fast Ethernet> port 0x2100-0x217f mem 0x204000-0x20407f irq 26 at device 6.0 on pci4
de2: 21140A [10-100Mb/s] pass 2.2
de2: address 00:00:bc:11:74:85
de3: <Digital 21140A Fast Ethernet> port 0x2180-0x21ff mem 0x206000-0x20607f irq 27 at device 7.0 on pci4
de3: 21140A [10-100Mb/s] pass 2.2
de3: address 00:00:bc:11:74:84

cards really worked. i tested on i386 platform.
all ports i found in dmesg on my sparc64 and ifconfig. but... it's no worked.

dc(4) problems: 
1. if i insert patchcord to any ports - any lamps do not light.
2. strange MAC address on dc1

de(4) problems:
1. if i insert patchcord to any ports - link lamp is flashed. ~2 seconds on,
~1 second off.
2. on another server in this segment i not have ARP address.

can anybody help me?

P.S. sorry for my bad english.

Maxim Mazurok  (MMP2-RIPE)

More information about the freebsd-sparc64 mailing list