ultra5/cmd646 hang

Garance A Drosihn drosih at rpi.edu
Mon Nov 17 15:44:54 PST 2003

At 1:04 PM -0800 11/17/03, Doug White wrote:
>On Fri, 14 Nov 2003, Doug White wrote:
>>  > FreeBSD 5.1-CURRENT #2: Fri Nov 14 10:51:48 PST 2003
>>  >     dwhite at dwsparc.looksmart.com:/usr/src/sys/sparc64/compile/SPARC
>>  > Preloaded elf kernel "/boot/kernel/kernel" at 0xc0330000.
>>  > Timecounter "tick" frequency 270000000 Hz quality 0
>>  > real memory  = 134217728 (128 MB)
>>  > avail memory = 104366080 (99 MB)
>>  > cpu0: Sun Microsystems UltraSparc-IIi Processor (270.00 MHz CPU)
>Next chapter in the saga.
>Working from 11/1 source still, I tried compiling without
>OFW_NEWPCI.  The IRQs show up in the boot -v output now
>but still aren't being serviced by the ata_*_intr routines.
>So there's still a disconnect.
>The disk drive in this machine is in need of help so I'm
>going to zero and reinstall the system from 5.1-RELEASE,
>then continue searching.  Not sure where to go next, though.

Well, for what it's worth I hit something vaguely similar on
my Ultra-10, when I tried to upgrade it to an 11/11 snapshot
of current.  In fact, I first hit the problem on a previous
upgrade attempt (maybe a week or two earlier), but at that
time I simply rebooted into an earlier kernel and temporarily
forgot about the whole thing.

In my case, the bootup process would get to:

atapci0: <CMD 646 WDMA2 controller> port
00010-0xc00017,0xc00008-0xc0000b,0xc00000-0xc00007 at device 3.0 on pci1
atapci0: [MPSAFE]
ata2: at 0xc00000 on atapci0
ata2: [MPSAFE]
ata3: at 0xc00010 on atapci0
ata3: [MPSAFE]
pcib2: <APB PCI-PCI bridge> at device 1.0 on pci0
pci2: <OFW PCI bus> on pcib2
Timecounters tick every 10.000 msec
ad0: WARNING - SETFEATURES recovered from missing interrupt
ad0: WARNING - SETFEATURES recovered from missing interrupt
ad0: WARNING - SET_MULTI recovered from missing interrupt
ad0: WARNING - SETFEATURES recovered from missing interrupt
GEOM: create disk ad0 dp=0xfffff80000756ec0
ad0 4103MB <ST34342A> [8894/15/63] at ata2-master WDMA2
acd0: WARNING - MODE_SENSE_BIG recovered from missing interrupt
ata3: resetting devices ..

and then completely freeze up.  the only thing I can do is
power-off and power-on again.

I haven't said anything, because in my case I happen to
comment out the 'options SMP' clause in the kernel, and
those '[MPSAFE]' lines got me thinking that maybe this
system-hang was my own fault.  My problem may very well be
different than yours, given that I seem to be hanging at a
different spot.

Also note that this Ultra-10 has a relatively old disk, which
might explain all those complaints from SETFEATURES.

Unfortunately, I then mistakenly blew away my working kernel,
so right now I can't boot up the machine at all.  So I will
also be reinstalling from 5.1-RELEASE and seeing what I can
figure out from there...

Garance Alistair Drosehn            =   gad at gilead.netel.rpi.edu
Senior Systems Programmer           or  gad at freebsd.org
Rensselaer Polytechnic Institute    or  drosih at rpi.edu

More information about the freebsd-sparc64 mailing list