Resolved, was RE: Intel Pro/1000 82540 Ethernet, was RE: SuperMicro X5DEI-GG

Guy Helmer ghelmer at palisadesys.com
Fri May 16 07:53:56 PDT 2003


(Apology for the crosspost - I queried both smp and net)
On May 15, 2003 5:00 PM I wrote:
> Originally I wrote to smp at freebsd.org:
> > Has anyone had positive or negative experience with the
> > SuperMicro X5DEI-GG
> > dual-Xeon motherboard?  It seems to work OK on a uniprocessor kernel,
but
> > FreeBSD 4.8 SMP kernels lock up after the "mounting root" message or
after
> > ifconfiging lo0 in the startup scripts.  Our first machine may just be
> > flaky, so I'll try another one as soon as possible...
>
> I seem to have isolated the problems with SMP on this machine to the
> built-in Intel Pro/1000 (82540) Ethernet interfaces.  The machine *nearly*
> freezes after ifconfig is run during startup.  It can respond to
> the keyboard
> (accepting characters) the first few times I unplug/plug the
> Ethernet cable
> from em0 and cause link down/up messages on the console.  This
> only works a few
> times before the keyboard becomes completely unresponsive.  I've
> tried a 4.8-RELEASE
> and a 4.9-STABLE kernel cvsuped today.  Any suggestions would be
> appreciated.

It turned to be a timer problem.  The SMP kernel didn't seem to be receiving
timer interrupts.  I removed the apm device from my kernel config, and now
the kernel reports:

APIC_IO: Testing 8254 interrupt delivery
APIC_IO: Broken MP table detected: 8254 is not connected to IOAPIC #0 intpin
2
APIC_IO: routing 8254 via 8259 and IOAPIC #0 intpin 0

and now it works fine.  Thanks to pdeuskar for a suggestion regarding if_em
that allowed me to boot the machine to the point where I could diagnose the
real problem.

Guy



More information about the freebsd-smp mailing list