freebsd-update in jails: merge fails for files that only differ in rcs?

Mathias Picker Mathias.Picker at
Tue May 4 10:48:22 UTC 2021

Hi all,

I’m in the process of updating my servers from 12.2-RELEASE-p6 to
13.0-RELEASE. This worked fine for the host. This now runs 
13-RELEASE, the jails are still running 12.2 world.

For the jais, running

- - - - - - - - -
freebsd-update -b /path/to/jail --currently-running 12.2-RELEASE 
-r 13.0-RELEASE upgrade
- - - - - - - - -

leads to loads of

- - - - 
The following file could not be merged automatically: [some config 
Press Enter to edit this file in vi and resolve the conflicts
- - - - - - 

for files that differ only in rcs line.

Before spending more time: does anyone know what’s going on here 
and has an idea how to fix this.
It’s 50+ files per update, that’s a bit too much for 6 jails.

I already looked through freebsd-update, found the samef function, 
recreated the 12 and 13 files for csh.login and ran only the samef 
function: this came up ok, i.e. identified both versions as the 

Where to look next?

The jails are vnet jails set up using jails.conf and bsdinstall, 
updated before using freebsd-update fetch install, which worked 
fine, connected to the outsinde via an if_bridge and work fine in 
all other aspects, i.e. pkg -j jail install whatever works fine, 
as does pkg -j update, and running web apps reachable from the 
outside, reaching other jails for api calls, everything works 

Thanks, Mathias
Mathias Picker
Mathias.Picker at

virtual earth Gesellschaft für Wissens re/prä sentation mbH
Westendstr. 142
80339 München
089 / 1250 3943

More information about the freebsd-questions mailing list