Installting FreeBSD on and old Thinkpad X31

Gordon Bergling gbergling at
Fri Apr 30 11:20:13 UTC 2021

On Fri, Apr 30, 2021 at 12:19:39PM +0200, Fernando Apesteguía wrote:
> On Fri, Apr 30, 2021 at 12:17 PM Gordon Bergling <gbe at> wrote:
> > Hi,
> >
> > I recently got and old Thinkpad X31 on which I would like to install
> > FreeBSD on it. I tried to boot 13.0-RELEASE and 12.2-RELEASE, but the
> > boot stops with "Root mount waiting for: usbus0 usbus1 usbus2 usbus3 cbb0 cbb1 CAM"
> >
> > I tried to boot without ACPI and in SAFE mode, but had no luck with these options.
> >
> > Has anyone a hint, how to install and properly boot FreeBSD on this old laptop?
> Super long shot, but try:
> hw.usb.no_boot_wait=1
> and
> and see if that helps.

I tried both variables but the boot still hangs with aboth mentioned error message
minus the usbus{0,1,2,3} part. I would think it is something related to the cardbus
stuff from cbb0 and cbb1.

I'll take a look at the man pages if this cardbus stuff can be somehow disabled.


More information about the freebsd-questions mailing list