X does not work as regular user, but it does at root

Antonio Olivares olivares14031 at gmail.com
Sat Apr 17 00:48:18 UTC 2021

On Friday, April 16, 2021, Gary Aitken <freebsd at dreamchaser.org> wrote:
> On 4/16/21 7:28 AM, Antonio Olivares wrote:
>> I have succeeded in installing FreeBSD 13 on an old eight core
>> machine.  I created a regular user, but cannot login to X.  I am
>> sending this from root account.
>> Xorg.conf
>> I am attaching tmp.txt from working root.  I have captured the output
>> from /var/log/Xorg.log.* from when I try to run startx as regular
>> user.
>> Thank you in advance.
> It looks like some kind of keyboard issue, judging from the log file,
> even though it says it is not fatal.
> You might check the permissions on the tree /usr/local/share/X11/xkb
> Gary

Dear Sir

You are correct in your assessment.  The folder /tmp is not writable by my
user and as a result cannot create the /tmp/k* file by keyboard-config.
Reading the file permissions should be 1777 so as root I ran chmod 1777

But after shutdown (does not shutdown) I press reboot, all is lost and upon
logging in and running startx the same thing happens.  I have to login as
root run startx, run chmod 1777 /tmp/*, logout and then I can login as a
regular user.  How can I check the permissions? On another machine I ran
13.0Beta1 all the way to release most things are working great (except java
web start), but I am limited in troubleshooting these things.  I have to
use webcam, and the webcam was blinking when using Google meets but another
plugin(hue viewer ) helps stabilize the webcam.

Thank you for your help.

Best Regards,


More information about the freebsd-questions mailing list