Xorg broken after upgrade to 12.2

Polytropon freebsd at edvax.de
Mon Nov 2 09:08:40 UTC 2020

On Mon, 2 Nov 2020 09:13:37 +0100, Morten Bo Johansen via freebsd-questions wrote:
> I installed an update of drm-legacy-kmod and now at least
> /dev/dri/card0 is created and the video error message has gone.
> However, I still can't start the X server. The only error
> message which is left in Xorg.0.log is this
>     [  2333.719] (EE) synaptics: SynPS/2 Synaptics TouchPad: Kernel bug: min == max on ABS_X/Y
> But I suppose this is not the reason? I tried to plug in a
> mouse just to bypasss the need for the toucpad but I still
> can't start the server?

That seems to be related to the (changed) way X now handles
input devices - old: libinput; new: evdev, if I understood
that correctly...

> There are some modular configuration files under xorg.conf.d/
> that I did not create
>    /usr/local/share/X11/xorg.conf.d/10-quirks.conf
>    /usr/local/share/X11/xorg.conf.d/20-evdev-kbd.conf
>    /usr/local/share/X11/xorg.conf.d/40-libinput.conf
> Should I remove them?

For testing, yes. Maybe there is something offending?
Also note that "old" keyboard configuration might not
work anymore, "new" keyboard configuration is needed
then. My solution was to add

	setxkbmap -rules evdev -layout de

to my user's ~/.xinitrc file and remove the partial
xorg.conf file /usr/local/etc/X11/xorg.conf.d/kbd_de.conf.
That of course is not an elegant solution, but worked.
However, if you're using a display manager and don't
want to use a non-US keyboard layout for it - well,
that's an entirely different problem. ;-)

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list