installation of 12.1R and 11.3R fails

Donald Wilde dwilde1 at
Mon May 25 16:03:36 UTC 2020

> Sometimes a specific combination of
>        { GPT | MBR | dedicated } x { BIOS | UEFI }
> can cause problems. It _should_ not, though.

You would think, wouldn't you? When I enabled UEFI, it promptly
ignored everything except my NICs so that was out. Using Legacy BIOS
it successfully built and allowed access to my system but only with
MBR-format file system. No GPT worked, at least with <AUTO>

> > I did have a glitch that led to a recursive stack crash, though,
> > forcing a reinstall. Updating the Handbook required me to build both
> > graphviz and vala, but neither of them would work without already
> > having a graphviz and vala on the system. Install with 'pkg install'
> > worked.
> It would be very strange if there was a "cyclic dependency"
> for those ports... however, using "pkg install" solves most
> problems with ports. :-)

As I say, /usr/ports/misc/freebsd-doc-en did me in. Corrupted the
whole system. Anybody else want to play guinea pig?

Steps to reproduce:

1) Update to 12-STABLE from 12.1R
2) Update the Handbook installation (without first installing
dependencies graphics/graphviz and lang/vala)

Reminded me of how much a 'learning experience' FreeBSD is... This
port is such an amazing, layered set of dependencies it is starkly
amazing that it can be made to work at all.

Vala? WT[DELETED] is vala? I had to look it up! :)

The flexibility of FreeBSD can be tiresome at times but that
configurability will come to my rescue at some point.

Game on, and again, thanks for all the advice! :D

Don Wilde
* What is the Internet of Things but a system *
* of systems including humans?                     *

More information about the freebsd-questions mailing list