ZFS system can no longer boot - zfs_alloc()/zfs_free() mismatch

Joseph Mingrone jrm at FreeBSD.org
Fri May 8 16:55:03 UTC 2020

Toomas Soome <tsoome at me.com> writes:

>> On 8. May 2020, at 16:32, Joseph Mingrone <jrm at FreeBSD.org> wrote:

>> Toomas Soome <tsoome at me.com <mailto:tsoome at me.com>> writes:

>>>> On 8. May 2020, at 16:13, Steve Wills <swills at FreeBSD.org> wrote:

>>>> I didn't solve it, I avoided it by renaming the kernel directory and reinstalling the kernel, forcing the bits to be in a different physical location on disk... The only theory I had at the time was that the bits were beyond some arbitrary 4G limit or something, but that was just a wild idea. Good luck, that's super frustrating.

>>>> Steve

>>> I guess we better backport the zfs_alloc/zfs_free removal code…  You can use loader from current meanwhile.

>>> rgds,
>>> toomas

>> We tried loader/zfsloader from current, but the got the same error.

>> Joe

> That is not quite possible as current has zfs_alloc() and zfs_free() removed and we use malloc()/free() instead.

> rgds,
> toomas

After using a loader from current (2020-04-10) *and* linking zfsloader to it, the error is:

panic: free: guard2 fail @ 0xd1e054a0 + 13 from unknown:0

Also tried with Allan's CURRENT gptzfsboot and the panic was the same.


>>>> On 5/7/20 7:59 PM, Joseph Mingrone wrote:
>>>>> Hello everyone,
>>>>> As it says in the subject line, my system stopped booting for some
>>>>> unknown reason.  It might have been after upgrading from 12.1-p2 to
>>>>> -p4, but I'm unsure.  It sounds similar to this issue:
>>>>> https://twitter.com/alelab_/status/1222437570501644291
>>>>> Allan and I tried debugging for a few hours today, but without
>>>>> success.  We tried replacing the boot code and the loaders, but the
>>>>> result was the same.  We also tried booting from a usb thumb drive,
>>>>> then `set currdev=zfs:zroot/ROOT/default:` and `boot`, but the same
>>>>> error is shown.
>>>>> Steve and Kyle, did you ever solve this problem?
>>>>> Thanks,
>>>>> Joe

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 987 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20200508/8365cec2/attachment.sig>

More information about the freebsd-questions mailing list