ZFS system can no longer boot - zfs_alloc()/zfs_free() mismatch

Joseph Mingrone jrm at FreeBSD.org
Fri May 8 13:32:08 UTC 2020


Steve Wills <swills at FreeBSD.org> writes:

> I didn't solve it, I avoided it by renaming the kernel directory and reinstalling the kernel, forcing the bits to be in a different physical 
> location on disk... The only theory I had at the time was that the bits were beyond some arbitrary 4G limit or something, but that was just a 
> wild idea. Good luck, that's super frustrating.

> Steve

Interesting.  Was this with your X220?  If so, maybe there is something
up with the BIOS.  In case it's useful, this is an X220 with 8 GB RAM.

% zpool status
  pool: zroot
 state: ONLINE
  scan: scrub repaired 0 in 0 days 00:49:21 with 0 errors on Thu May  7 17:30:55 2020
config:

        NAME            STATE     READ WRITE CKSUM
        zroot           ONLINE       0     0     0
          mirror-0      ONLINE       0     0     0
            ada0p4.eli  ONLINE       0     0     0
            ada1p4.eli  ONLINE       0     0     0

errors: No known data errors

% zpool list
NAME    SIZE  ALLOC   FREE  CKPOINT  EXPANDSZ   FRAG    CAP  DEDUP  HEALTH  ALTROOT
zroot   228G   198G  30.0G        -         -    74%    86%  1.00x  ONLINE  -

Don't judge me too harshly about the free space. :)

Joe

> On 5/7/20 7:59 PM, Joseph Mingrone wrote:
>> Hello everyone,
>> As it says in the subject line, my system stopped booting for some
>> unknown reason.  It might have been after upgrading from 12.1-p2 to
>> -p4, but I'm unsure.  It sounds similar to this issue:
>> https://twitter.com/alelab_/status/1222437570501644291
>> Allan and I tried debugging for a few hours today, but without
>> success.  We tried replacing the boot code and the loaders, but the
>> result was the same.  We also tried booting from a usb thumb drive,
>> then `set currdev=zfs:zroot/ROOT/default:` and `boot`, but the same
>> error is shown.
>> Steve and Kyle, did you ever solve this problem?
>> Thanks,
>> Joe


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 987 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20200508/5656d9c7/attachment.sig>


More information about the freebsd-questions mailing list