ZFS system can no longer boot - zfs_alloc()/zfs_free() mismatch

Joseph Mingrone jrm at FreeBSD.org
Fri May 8 00:25:54 UTC 2020

Joseph Mingrone <jrm at FreeBSD.org> writes:

> Hello everyone,

> As it says in the subject line, my system stopped booting for some
> unknown reason.  It might have been after upgrading from 12.1-p2 to
> -p4, but I'm unsure.  It sounds similar to this issue:
> https://twitter.com/alelab_/status/1222437570501644291

> Allan and I tried debugging for a few hours today, but without
> success.  We tried replacing the boot code and the loaders, but the
> result was the same.  We also tried booting from a usb thumb drive,
> then `set currdev=zfs:zroot/ROOT/default:` and `boot`, but the same
> error is shown.

> Steve and Kyle, did you ever solve this problem?

> Thanks,

> Joe


After half a day of pulling my hair out, I just tried booting from an
older kernel (from before `freebsd-update` to 12.1-p4) and it booted.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 987 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20200507/a0b9f57b/attachment.sig>

More information about the freebsd-questions mailing list