Microsoft Teams for Linux

Maciej Suszko maciej at
Thu May 7 21:58:24 UTC 2020

On 5/7/20 5:50 PM, Damjan Jovanovic wrote:
> On Tue, May 5, 2020 at 2:52 PM Maciej Suszko <maciej at
> <mailto:maciej at>> wrote:
>     Hi,
>     I'm wondering if anyone tried to use Microsoft Temas either web version
>     or desktop app... Web version does work but making audio/video call
>     isn't officialy suppported, so you need to spoof user-agent to make it
>     partially working - but from time to time MS change something and it
>     just stop working. In the past weeks I was able to make audio calls, now
>     it's not possible (neither Firefox nor Chrome)
>     I tested my webcam and mic on and it's
>     all working, so problematic is the web application from MS.
>     Desktop application - here are two options, one for Linux, one for
>     Windows. I tried to run the Linux version using linuxulator,
>     brandelf-ing all the binaries but with no success...
> The Linux version is buggy. The microphone often doesn't work.
> Wine seems to be 1 bug away from running the Windows version:
> Since I am forced to use Teams, I might take a look at it soon.

I tried that too... and still trying to get it to work. Now I have a
problem with current emulators/wine-devel - amd64 version does not work
at all, emulators/i386-wine-devel does not support staging, which is
required to build runas.exe.
Building emulators/wine-devel from ports on i386 chroot (with staging
enabled) throws some errors which I can't cope with:

gcc9 -o wine main.o -Wl,--rpath,\$ORIGIN/../libs/wine -Wl,--export-dynamic \
  -Wl,-Ttext-segment=0x60000000 -Wl,-z,max-page-size=0x1000 -lwine
-lpthread \
  ../libs/port/libwine_port.a -L/usr/local/lib -L../libs/wine
-fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc9
/usr/local/bin/ld: main.o: in function `main':
main.c:(.text.startup+0x1b0): undefined reference to `wine_get_patches'
collect2: error: ld returned 1 exit status
gmake[3]: *** [Makefile:260: wine] Error 1
gmake[3]: *** Waiting for unfinished jobs....
/usr/local/bin/ld: main.o: in function `main':
main.c:(.text.startup+0x1b0): undefined reference to `wine_get_patches'
collect2: error: ld returned 1 exit status
gmake[3]: *** [Makefile:264: wine-installed] Error 1
gmake[3]: Leaving directory
gmake[2]: *** [Makefile:8940: loader] Error 2
gmake[2]: *** Waiting for unfinished jobs....
gcc9 -o widl client.o expr.o hash.o header.o proxy.o register.o server.o
typegen.o typelib.o \
  typetree.o utils.o widl.o write_msft.o write_sltg.o
parser.yy.o \
  ../../libs/port/libwine_port.a ../../libs/wpp/libwpp.a
-L/usr/local/lib -fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc9
gmake[3]: Leaving directory
gmake[2]: Leaving directory '/usr/ports/emulators/wine-devel/work/wine-5.7'

I even tried to copy runas.exe from some other wine binary build, but
I'm not sure it's the way to go - wine throws exception, which tells me
nothing :)

wine: Call from 0x7bc77671 to unimplemented function
ntdll.dll.__wine_create_default_token, aborting
wine: Unimplemented function ntdll.dll.__wine_create_default_token
called at address 7BC77671 (thread 0009), starting debugger...

At work I use Teams on a daily basis and it's more and more pain in the
a** having problems with audio/video calls. Switching to other OS is the
last thing I'd like to do...

BTW Some of my coworkers use Linux and they don't have much problems
with desktop app, although it's quite cpu/memory hog.

regards, Maciej Suszko.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-questions mailing list