Exim - retry time not reached for any host

Daniel Lysfjord lysfjord.daniel at smokepit.net
Mon Jun 22 10:27:38 UTC 2020

On 22.06.2020 10:46, Mike Clarke wrote:
> On Monday, 22 June 2020 08:36:45 BST Daniel Lysfjord via freebsd-questions wrote:
>> To clarify: did 4.94 fail to connect every time on a *new* email?
> Yes, every attempt to send a new email failed on the initial connection. It would eventually
> succeed after several retries but that could take an hour or more.
> In the case of the example for which I showed results there are 4 IP addresses for
> mail.gridhost.co.uk so there were 4 failures for the initial attempt to connect and 4 more for
> each retry.
> When a connection was finally made it was with the first IP tried for that attempt but I don't
> know if this was the case for every successful connection.

In your route_list, you have mail3.gridhost.co.uk, not that it should 
matter, but you could try changing that to mail.gridhost.co.uk (or, 

It seems like your successful attempt are at, but fails at, and

Could it be that you're finding a corner case in exim, because of that 
circular dns resolving? mail.gridhost.co.uk does have multiple A 
records, one of those has a PTR back to mail.gridhost.co.uk, where the 
rest does not.

Grasping at straws here^^ If this is of no help, I can't see any other 
way around than using tcpdump on the connections, to see what's going on.

The log line:
TLS error '(SSL_connect): error:00000000:lib(0):func(0):reason(0)
is in my search history, so I've been hit with something kicking out the 
same error somewhere some time, but I can't remember what it was:)

What SSL library is your exim compiled with?


More information about the freebsd-questions mailing list