[WORKAROUND] Re: odd issue affecting firefox (any version) on freebsd (any version)

tech-lists tech-lists at zyxst.net
Wed Jul 29 00:48:55 UTC 2020

On Wed, Jul 22, 2020 at 07:21:42PM +0100, tech-lists wrote:
>This is a really odd problem which I haven't a clue how to debug.
>I use fastmail.com for my email. Sometimes, I'll want to use a web browser
>(firefox in this instance) to look at mail via their webmail. I have, amongst
>other machines, my main desktop machine running 12-stable/kf5/plasma.
>If I use firefox at the site to compose email, I can compose it but when I try
>to send it I get "sending failed" and this is real, the mail is not sent. If I
>run firefox (same version) from an ubuntu machine, I *can* send mail.
>If I run iridium on the desktop machine and do the same thing, I *can* send
>I have tried this from a pristine freebsd-current vm as well. I get the same
>result as I do from my freebsd-desktop. That machine, as it's a vm, does not
>run a DE.
>fastmail support haven't a clue about this issue, not that I'd expect them to
>in this instance as it's far outside of their support remit.
>So why can I not use *specifically freebsd firefox* to send email from
>fastmail.com's webmail? How can I debug this? Is it a headers thing?

It seems the problem was being caused by Firefox on freebsd giving
fastmail a fractional time-zone offset causing them to
generate an invalid offset in the JSON fastmail was sending to the server. Because
of this the server was rejecting the message resulting in the "Send Failed". 

Fastmail have worked around this issue and made a change that converts the
offset to a whole number, and now firefox (freebsd) works. But this, to me,
looks like a freebsd firefox problem and not directly a Fastmail one really.
So i'll raise a PR in ports

To reproduce, open a javascript console and enter 
new Date().getTimezoneOffset()
and ctrl-enter and it should produce a whole number as output. Firefox on my
freebsd desktop outputs -59.55. My timezone is set Europe/London.

For comparison, iridium on the same system shows -60 and firefox on Linux Mint
18 gives 0. Firefox installed from official freebsd pkg repos running a very
recent -current shows the same as my 12.1 desktop - -59.55

So it does seem to be firefox on freebsd and only freebsd and it doesn't
matter if it's 12.1-stable or current. I have not tried firefox-esr, i'll do
that next. The firefox on the current vm is vanilla, no addons at all are

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20200729/0c8e3f4b/attachment.sig>

More information about the freebsd-questions mailing list