Problem with unbound resolving host

Doug Hardie bc979 at
Wed Jul 15 19:36:39 UTC 2020

> On 14 July 2020, at 16:46, Jerry <jerry at> wrote:
> On Tue, 14 Jul 2020 12:34:59 -0400, Lowell Gilbert stated:
>>> FreeBSD 11.4-RELEASE-p1
>>> I have: local_unbound_enable="YES" in my /etc/rc.conf file. The
>>> problem is with some utility programs like "curl" or "wget"
>>> When using either program to assess "" a
>>> failure message is emitted similar to the following:
>>> curl
>>> curl: (6) Could not resolve host:
>>> The "nameserver" is set to "" when that occurs. If I modify
>>> it as shown below to "" everything works fine.
>>> nameserver
>>> options edns0  
>> I'm sure that is in resolv.conf, but you should mention things like
>> that.
>> I'm also assuming that the machine you're trying this on actually has
>> the address Otherwise, um, yes, that's what should happen.
>> Check if you're specifying "interface:" in your unbound.conf file. If
>> you do, you want to include in the set you specify.  However,
>> unless you have a good reason, don't override it at all.
>> Be well.
> The router's address is "". The machine's address is
> "". After every reboot, the address in the resolv.conf
> file is reset to, which usually works, but not always.
> This problem only started after updating from FreeBSD 11.4-RELEASE-p0
> to "p1". I have no idea what that could have done though.

I had the same problem a year or so ago.  It was consistent on all devices, although the problem domains tended to be different on each device.  I thought it was my provider's DNS and called them.  They sent out a tech who had just corrected a similar problem earlier that day.  He replaced my modem/router and the problem went away.  In my situation, resolving the problem domains using the modem/router's internal client worked fine.  Using my clients didn't.  Using worked consistently from all.

-- Doug

More information about the freebsd-questions mailing list