Child process pid=67810 terminated abnormally: Bus error

Victor Sudakov vas at
Sun Jan 19 14:48:24 UTC 2020

Victor Sudakov wrote:
> On one of my VMs, I get the following error:
> $ pkg info > /dev/null
> Child process pid=67810 terminated abnormally: Bus error
> I've tried "pkg update -f" suspecting the repo database being corrupt or
> out of sync, but this did not help.
> How can I try and find the cause of the error? I've tried "ktrace -i pkg info",
> there is the output:

If anybody cares. There was a duplicate line 


in /usr/local/etc/pkg.conf. (One line was created by ansible, the other
identical line was a leftover from a previous manual configuration).

After the removal of the extraneous line, the problem is gone.

Victor Sudakov,  VAS4-RIPE, VAS47-RIPN
2:5005/49 at fidonet
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 455 bytes
Desc: not available
URL: <>

More information about the freebsd-questions mailing list