usb tape drive issue

thor thor at
Sat Jan 4 05:53:53 UTC 2020


Well, it's quite possible that the problem is with the block size which 
could be unsupported. The second problem could be the block size set by 
mt command or physical limit which is incompatible with cpio 
requirement. Use "mt rblim" and "mt blocksize NNNN".

There are different reports about cpio, some tell that they use only 512 
bytes while tar uses 10240 and dd uses any size.

You could simulate the problem using dd with different block sizes.

Then, while I believe that USB is NOT a professional interface I think 
it's not an USB problem. Have you analyzed the error messages, what are 
the errors?

I think that SCSI LVD nears end of life. So unless you already have it 
it would be quite useless.

I'd recommend instead a used LTO-4 drive or, if you have enough money, 
any newer level one, with SAS or FC interface. I had no problems with them.

You should look for a model with a Single Character Display (IBM).

For SAS I've tried HP P-400 and DELL PERC-6/i, PERC is preferred but be 
warned that they both do NOT support HDDs bigger than 2 terabytes. I 
have ServeRaid M5015 but have not tried it.

For FC interface I recommend Qlogic controllers. Emulex controllers are 
strongly discouraged. You also need a cable (Double orange cable with 
gray LC connectors. Yellow cable with blue connectors is NOT OK!!!)

If the system hangups during boot it could be necessary to disconnect 
the FC cable before boot and reconnect it after boot or power down the 
drive during boot.

The LTO drives are to be tuned to fixed or variable block sizes 
according to your needs, and they use logical blocks so you don't lose 
too much when you use outdated programs writing too short blocks.

LTO drives consume up to 50W of power and require good air flow for 
cooling!!! Be warned that data rate is higher than the one of HDD of 
similar age. So maybe it's better to make an archive to the file on 
separate HDD and then write it separately.

You also need a cleaning cartridge.

On 01/04/20 03:48, Wayne Anschutz wrote:
> Folks,
> I'm new at this bsd OS, but did get an xinuos open server 10 operating
> which is BSD. I've managed to get everything working with some trial and
> error picking the correct ports for necessary libraries.  The BSD os is
> stable version 11.3.
> The problem popped up when I tried to make a backup tape using a usb dat160
> internal drive.  After testing a lot I found that the drive would read
> tar and dd formats correctly.  It did only a flawed read on cpio tapes.  It
> always failed on any write with CAM errors and scsi errors.  Research on
> the web proved that this is not an uncommon problem with usb storage
> devices.  I am not interested in being a freeBSD test bed!  I need a stable
> OS for my customers.
> My first question - would updateing to stable 12.1 solve this?  If so what
> are the updateing pit falls?  Would switching to a dat160 scsi lvd drive
> solve the problem?
> Thanks all,
> Wayne Anschutz
> Computer Resources, Inc.
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list