Boot problems with a new system

Carl Johnson carlj at
Thu Dec 10 03:14:10 UTC 2020

Kyle Evans <kevans at> writes:

> On Wed, Dec 9, 2020 at 6:35 PM Carl Johnson <carlj at> wrote:
>> Hello,
>> I have a new system that I have installed FreeBSD 12.2-RELEASE (amd64)
>> onto, but it won't boot back from the disk.  It installed properly and
>> it has booted a couple of times, but lately it always hangs in the
>> middle of the boot loader menu.  It always prints the first five menu
>> entries, but then hangs when it should print out the kernels that are
>> available.  I can still boot with the memstick and "zfs import" the
>> pool, and the pool appears fine.  I have tried searching the web, but
>> haven't found anything that helps.
>> These are all loader.conf settings I have tried that don't help:
>> vfs.zfs.cache_flush_disable="1"
>> loader_delay="3"
>> boot_verbose="YES"
>> verbose_loading="YES"
> Try adding:
> kernels_autodetect="NO"
> Thanks,
> Kyle Evans

Thanks Kyle,

It boots perfectly with that line present.  I commented out the other
test lines and it still boots consistently, but still hangs without the
autodetect line.  Is there something else I should be doing, or just
leave it like this?

Thanks again!

Carl Johnson		carlj at

More information about the freebsd-questions mailing list