Mate And Slim Load But Don't Work

B J va6bmj at
Sun Aug 9 14:23:55 UTC 2020

This one has me baffled.

A few days ago, I did my monthly system FreeBSD upgrades.  The results for
one machine didn’t go quite as expected as Slim wouldn’t allow me to log
on.  I disabled Slim in /etc/rc.conf through single-user mode and I managed
to resolve it by what I found at:

After running the following:

pkg autoremove -y
pkg update -f
pkg upgrade -f

I enabled Slim again and I’m able to log in again.  The only problem is
that Mate apparently doesn’t recognize my monitor.

Yesterday, I tried the same thing on the other installation on the same
machine.  The only thing I did differently was to enable Slim before

Slim loads but doesn’t appear to work as all I get is the command line
log-in prompt.  I thought the problem might be only with Slim, so I tried:

exec mate-session

after logging in (startx is apparently missing) and I got the following

Unable to init server:  Could not connect to  Connection refused

** (mate-session:963): WARNING**: 22:14:10.767: Cannot open display:

and I was returned to the log-in prompt.

I don’t think it’s a problem with the monitor as I tried the same thing
with two others I had on hand.

Any suggestions as to what do to fix it?  Was a file corrupted or do I have
to re-install something?

As much as I like Mate and Slim, I’m seriously thinking of trying another
desktop.  I don’t particularly like Xfce, but it’s given me less trouble
than Mate has in recent months.  I’ve installed FreeBSD on another machine
with Lumina as the desktop, though it seems a bit quirky for me.  (For
example, Firefox loads, but I can’t get a connection to the Internet with
it.)  I’ll have to try it some more to see if I can figure it out.

Maybe I should be looking at something like GhostBSD.

Thank you.


More information about the freebsd-questions mailing list