replace disk in zpool - solved

David Christensen dpchrist at
Tue Apr 14 19:05:03 UTC 2020

On 2020-04-14 08:09, Lukasz wrote:
> On 4/1/20 23:43, David Christensen wrote:
>> On 2020-04-01 11:13, Lukasz wrote:
>>> On 3/30/20 21:02, David Christensen wrote:
>>>> On 2020-03-30 11:06, Lukasz wrote:
>>>>> this behavior was due to errors in zpool.
>>>> Solved how?  Could you please expand upon errors in zpool and 
>>>> how you got past them?

>>> I restored corrupted files from backup.

>> That is something I would like to learn how to do on ZFS.  Could 
>> you please elaborate:
>> - How did you determine what files were corrupt?
>> - How do you perform backups?
>> - How did you restore the corrupted files?

> information about corrupted files is at the end of 'zpool status' 
> output. I perform backup by zfs snapshot and zfs send/recv 
> (incremental> snapshots) to an other server. Saying restore form
> backup I mean copy correct files from previous snapshot.

Okay.  I also backup ZFS filesystems via snapshots and incremental 

Looking at your previous post:

On 2020-03-24 14:15, Lukasz wrote:
 > # zpool status -v mypool

 > errors: Permanent errors have been detected in the following files:

And this Oracle document:

So, the corruption in your ZFS pool was a file in a dataset that was not 
mounted (?).  Recovery consisted of mounting the dataset and using cp(1) 
to copy a non-corrupt version of the file to the path of the corrupt 
file (?).


More information about the freebsd-questions mailing list