AMD driver/Xorg/KDE5 issue

Rob mecholomaniac at
Sat Sep 14 22:06:36 UTC 2019

Dear FreeBSD questions

I have for a number of weeks been attempting to install FreeBSD 12.0, 
after a lot of frustration I have got it to boot on an old (~7yr old) 
laptop of mine. I have got to the point where I am attempting to install 
KDE5 but before that I have tried to see if startx works first, it doesn't.

I have an odd dual AMD graphics set-up (a Radeon HD 6400M/7400M with an 
APU whose model I don't remember) so I tried to install the drm-kmod 
package as the xorg var log file didn't seem to be able to find a usable 
driver, but when I do I get:

[1/3] Extracting gpu-firmware-kmod-g20190620: 0%
[1/3] pkg: Fail to create /boot/modules:No such file or directory
[1/3] Extracting gpu-firmware-kmod-g20190620: 100%

Having found this problem, I wiped the drive, reinstalled FreeBSD again 
and before rebooting the system, I created this directory in case it was 
some odd permissions issue, but I get the same message.

If anyone more competent than me (i.e. everyone) has an idea how I could 
fix this I would be grateful.

Also, I sent an email to the mailman on the FreeBSD mailing list 
regarding this issue but other than an 'awaiting approval' email I have 
not heard any more.  I believe that I am supposed to register as a 
member, I have registered on the forums as user In_Over_My_Head but I am 
not sure if that is the type of registration that the mailman is 
referring to.  It would help if certain things such as this were made 
clearer, especially if those heavily involved with this project wish to 
reach a potentially wider user base as some may consider such behaviour 
as rude.

Thank you for your time


Kind Regards

More information about the freebsd-questions mailing list