Pkg broken after 11.3 upgrade

Robert Fitzpatrick robert at
Mon Oct 28 17:06:50 UTC 2019

Polytropon wrote on 10/28/2019 12:01 PM:
> On Mon, 28 Oct 2019 08:19:49 -0400, Robert Fitzpatrick via freebsd-questions wrote:
>> After doing an upgrade from 11.2-RELEASE to 11.3-RELEASE, I could no
>> longer login via SSH. When I login from console, there are many packages
>> that generate segmentation faults including pkg when I tried to pkg
>> upgrade openssh or just pkg update...
>> root at db1: ~ # pkg update
>> /usr/lib/ Shared object has no run-time symbol table
>> I tried to deinstall pkg from ports manually and get these same errors
>> when trying to make install afterward. What can I do to get this
>> functional again?
> It might be possible to use the following command:
> 	# pkg-static -f update
> Seems that somehow your OS and ports (shared) library requirements
> got out of sync...

Yes, I did this and it says all my packages are up to date.


More information about the freebsd-questions mailing list