Avoiding LibreOffice DOS

Per Hedeland per at hedeland.org
Thu Oct 17 15:54:56 UTC 2019

On 2019-10-17 16:42, Kevin P. Neal wrote:
> On Thu, Oct 17, 2019 at 03:05:32PM +0200, Andrea Venturoli wrote:
>> If I issue "ulimit -v 2097152" and "ulimit -a" again, I still see the
>> same values as above.
>> So either "ulimit -v 2097152" did nothing or I'm not understanding it
>> correctly...
> It's a shell builtin, so it should be documented in the man page for
> the shell you are using. Which one is that? I just tried it with bash
> 5.0.11 and the output of ulimit -a looked correct. The /bin/sh that
> comes with FreeBSD 11.3 seems correct as well. Oh, but 11.3's csh
> didn't change the limit. Are you using stock csh by any chance?

The [t]csh builtin corresponding to [ba]sh's 'ulimit' is called 'limit':

pluto 1> which ulimit
pluto 2> which limit
limit: shell built-in command.
pluto 3> limit
cputime      unlimited
filesize     unlimited
datasize     33554432 kbytes
stacksize    524288 kbytes
coredumpsize unlimited
memoryuse    unlimited
vmemoryuse   unlimited
descriptors  234324
kqueues      unlimited
memorylocked 64 kbytes
maxproc      12171
sbsize       unlimited
swapsize     unlimited

A bit more verbose usage than 'ulimit', but has worked fine in all
FreeBSD versions where I've tried it. /usr/bin/ulimit obviously can't
work for changing the limits, why it (and /usr/bin/cd, /usr/bin/umask,
and a bunch of others like it) exists at all I'll leave for someone
else to explain (I think it's some POSIX requirement).

>> Once I solve the above, should I use -m instead of -v (or the
>> corresponding memoryuse insetead of vmemoryuse in /etc/login.conf)?
> No, I'd stick with "-v".

I think -d may also be worth a try...

--Per Hedeland

More information about the freebsd-questions mailing list