FreeBSD-12.1 on laptop

vm finance vm.finance2 at
Wed Nov 27 19:22:51 UTC 2019

Hi Theron,

Ok - it tried this:
make -C /usr/ports/graphics/drm-kmod deinstall clean install
make -C /usr/ports/graphics/drm-kmod deinstall
cd /usr/ports/graphics/drm-kmod
make install FORCE_PKG_REGISTER=1 /* make install failed suggested to set
this flag */
[drm-kmod-g20190710 gets installed]

this seemed to work but startx fails again (same framebuffer error).

I also tried to "kldload drm.ko" - still no luck!

BTW, if I go back to 12.0 RELEASE, would that solve the problem?
Ultimately, I need to rebuild with latest sources anyways to experiment
something w/ TCP stack,
so hopefully going back to 12.0 should fix - thoughts, please?

Any other ideas? Thanks a lot!

On Thu, Nov 28, 2019 at 12:36 AM Theron <theron.tarigo at> wrote:

> On 2019-11-27 09:20, vm finance wrote:
> > I tried to do:
> > pkg install drm-kmod
> On 2019-11-27 11:14, vm finance wrote:
> > Well, now after installing drm-kmod, system is in continuous reboot
> > mode..;(
> > Anything possible now?
> Sounds like this could be from the kernel panic I warned about. Please
> do (before attempting startx):
> make -C /usr/ports/graphics/drm-kmod deinstall clean install
> Then reboot and try again.
> That will remove the drm-kmod from pkg (which is for 12.0 kernel) and
> build the module for your 12.1 installation's kernel.

More information about the freebsd-questions mailing list