FreeBSD-12.1 on laptop

Karl Denninger karl at
Wed Nov 27 17:39:17 UTC 2019

On 11/27/2019 11:13, vm finance wrote:
> Ok - I deleted that faulty line from /etc/rc.conf and now system boots up.
> and tried:
> #kldload drm-kmod
> and fails saying "can't load drm-kmod: no such file/directory".
> Per another google post, it tried:
> #kldload drm2, and that worked (i.e. loaded)
> However startx is still failing - same framebuffer error.
> Could someone suggest how to fix this?
> Thanks so much for your help!

Yes.  Load the ports subsystem, compile drm-kmod from source and install
it, as I said before.

The pkg version WILL NOT WORK on 12.1 as it is a 12.0 package and the
kernel ABI changed between 12.0 and 12.1.

Karl Denninger
karl at <mailto:karl at>
/The Market Ticker/
/[S/MIME encrypted email preferred]/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4897 bytes
Desc: S/MIME Cryptographic Signature
URL: <>

More information about the freebsd-questions mailing list