12.1-STABLE r354923 snapshot install doesn't like manual ufs setup

tech-lists tech-lists at zyxst.net
Wed Nov 27 15:53:07 UTC 2019


On Wed, Nov 27, 2019 at 01:15:42PM +0100, Polytropon wrote:
>On Wed, 27 Nov 2019 03:37:39 +0000, tech-lists wrote:
>> Hi,
>> Got a new ssd so tried latest snapshot install to it. I wanted seperate /usr
>> /var and / partitions, also to enable trim, also two 16GB swap partitions,
>> so selected manual UFS, completed the install, reboot, cannot find kernel.
>Did you do this using the bsdinstall program, or manually
>via shell?

I don't know specifically if it was the bsdinstall program. I guess it was. It
was whatever is invoked after booting the install disk/image and then
selecting "Install".

>> Repeated the install the same way again with same result. Rebooted, ran
>> the installer for a third time, selected auto ufs and everything worked
>> as expected on reboot, but of course without the modifications I wanted.
>> Is this a known issue?
>Even though bsdinstall isn't that bad, I personally prefer
>to prepare the disk via shell commands manually before I
>return to bsdinstall, add the created partitions, and have
>the installer do it's work, in case I needed something that
>is "non-standard" (as you've described). This is because of
>my impression (I wouldn't call it an issue though) that the
>bsdinstall program doesn't understand when you leave its
>predefined path... ;-)

I'd say if it's not working as suggested or implied then it's broken, or why
have the manual option at all? I don't expect the consequence of selecting
this option to be "doesn't install a kernel" or "everything is installed, it's
just not bootable" without notification.

I've not encountered the issue before because my installation context is
mostly bhyve-based so I just accept the defaults. Because this is bare metal,
I was hoping to optimise the SSD somewhat.

>> Also, MBR is selected by default. SHould I be using GPT instead, nowadays?

>Probably yes. Use GPT. Use MBR only if you have a good reason
>to do so (inter-OS things might be such a case).

There should be a reason why this is selected as default. "Most x86 systems"
isn't enough. I'd fix this if I knew how. What is the GPT advantage?

thanks for the clarification
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20191127/d2e1262e/attachment.sig>

More information about the freebsd-questions mailing list